Announcement Announcement Module
Collapse
No announcement yet.
speedometer just stopped working Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • speedometer just stopped working

    so i drove my cj7 the other day, and the speedometer was just fine. i crank it up the next day and it is inop!!

    i searched for speedometer posts but found none that seemed to apply. anyone know where i should start checking for the problem?

    oh yeah... the odometer should stop too, right?

  • #2
    Pull the speedo cable off of the T/C under the Jeep. Have somone watch speedo to see if it moves while you spin center cable. you wont see too much movement unless you spin it with a drill. If it works fine check the gear in the t/c. If it doesent move pull the cable from the back of the speedo and have someone watch center while you spin it from under jeep. No movement = bad cable. If your jeep has cruise it might have a two piece cable with a conector right under the steering collum under the hood.

    Comment


    • #3
      Same problem here... how do you get the gear outta the transcase?

      Comment


      • #4
        Should have a bolt that holds down a fork that holds in speedo gear housing. Remove bolt, remove fork and pull gear housing out. The other gear is inside the t/c. I think you have to pull apart t/c to get to that one....never had a problem with that one.

        Comment


        • #5
          must be a different trans case...i cant find a bolt

          Comment


          • #6
            also make sure the cable "insides" engage the gear. after rebuilding my t-case I had no speedo; it turned out I had slid (or twisted) the end of the cable that threads onto the t-case farther down the cable, so that the inside did not touch the gear anymore.

            Comment


            • #7
              ?

              Originally posted by the wildebeest
              oh yeah... the odometer should stop too, right?
              Why did you ask that, Wildebeest? If your odometer is still working and your speedo isn't then it's definitely the speedometer. Something has given up the ghost in there.

              What year is your jeep? If you have the Dana 20 tcase the speedo drive gear is beneath where the cable screws in on the tcase. Like said, check the cable first. (That's the 'easy' fix.) I believe a 7/8" socket will take the drive gear 'housing bolt' or whatever that thing is called out then you can pull the 'driven' gear out and check it. The 'drive' gear for the 'driven' gear is on the output shaft of the t-case. If you have the Dana twenty you just remove the drive shaft, output shaft flange bolts and pull the output shaft assembly. I recommend that you get a decent manual if you don't have one. Also, take a look at the transfer case assemblies in the 4WD catalog and you'll see all the 'little' parts when you find your case in there.

              Comment


              • #8
                yeah, the odometer died with the speedometer, and i just wanted to make sure that sounded right. shouldn't that happen if the speedometer dies? i've got the d300 t/c, so if anyone has dealt with this situation on that, let me know.
                thanks

                Comment

                Working...
                X