Announcement Announcement Module
Collapse
No announcement yet.
Ignition Issues..... Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Ignition Issues.....

    I'm stumped. I've been dealing with a weak or dead battery, for a while. Then starter went bad. I've replaced both but the battery seems to maybe have a draw somewhere. I finally got time and great weather today and the battery was dead again, after cranking right up yesterday. I put the cables on to jump it, and the positive postoon the battery and clamp on the cable started sparking ang smoking like the cables were crossed. I disconnected them, and tried again. This time the Jeep cranked with the key off, so I disconnected and reconnected again. This time it starts but the starter won't disengage, so I killed it, and here I am. Battery, starter, solenoid, and neutral safety switch are all new. Could it be an issue with the key switch? I don't know where to go from here, or how to deal with the key assembly to test it.

    Any thoughts?

  • #2
    King
    there was just a recent post with similar problems to yours and if I remember correctly it was pointing to the ignition switch assembly.

    Comment


    • #3
      The key seems firm, meaning no play, the various stations of the turn seem good. there are two .....things on the column at the base of the dash, but I can't see or feel any rod. I'm not sure how anything would have been bent. I only have a Haynes, but it doesn't show what has been mentioned.

      Comment


      • #4
        Have you used a multi meter to test the voltage at the battery, the starter, etc. I would do this with the key in various positions. I have seen a bad starter (The slenoid if I recall correctly) cause problems like this. How old are the cables?

        Comment


        • #5
          Cables are all new within the last 60 days and maybe 30 miles. Surely the starter isn't bad again. I got a bad one back in January and had to replace it.
          No, I have not taken to the alt meter yet. When it started with connecting jumper cables while the key was off and out, I figured it was past a voltage issue.

          Comment


          • #6
            Maybe a stuck closed starter solenoid or not wired right? Just a guessing.

            Comment


            • #7
              I'll try the voltage thing when I get a chance. The solenoid is brand new from NAPA last week when the brand new starter fried and I replaced. The wiring on the solenoid wiring is pretty straight forward.

              BTW, what is the little tit on the bottom of the solenoid for? They have tried to sell me the one with two connectors on top and the cable posts on the side.

              Comment


              • #8
                BTW, what is the little tit on the bottom of the solenoid for? They have tried to sell me the one with two connectors on top and the cable posts on the side.[/QUOTE]

                King, heres a pic of my sol. Two of those nubbys and only one used. http://my.execpc.com/~gwilli/070807_files/July8_260.jpg This works fine on my 86 CJ.

                Comment


                • #9
                  Interesting. Mine has two on top with a factory harness that makes it pretty wormproof to cross, and a third wire from the harness that connects to the one on bottom. Maybe tied to the neutral safety switch or something?

                  Comment


                  • #10
                    Originally posted by kingchip View Post
                    Interesting. Mine has two on top with a factory harness that makes it pretty wormproof to cross, and a third wire from the harness that connects to the one on bottom. Maybe tied to the neutral safety switch or something?
                    Mine is pretty simple, Pos. and Neg. hookups on the sides, wire on the nubby from the ignition, ground wire running from mounting bolt. Cant remember what my original harness looked like?

                    Comment

                    Working...
                    X