Announcement Announcement Module
Collapse
No announcement yet.
Linux Help! Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Linux Help!

    alright i runing a dual boot system, madrake 10 and xp pro. grub is the boot loader and its set with a default to the linux partition. so well anyways when madrake is loading it gets hung up on loading the usb printer, i do have a printer hooked up by usb and if i unplug it still the same problem. about 10% of the time this wont happen and i can get into linux fine. i asked my friend hes a linux freak and he just told me that its just windows not playing nice. so is there anyway to ***** slaping windows into playing nice with linux?

    oh yea and this is all on one HD, when i installed mandrake i told it to go on a second HD but it just did not want to

    oh yea for got to mention that its not locked up, i can type anything in the detailed load screen is just does not move onto the next step

    any help would be great thanks

  • #2
    SheepJeep, I recommend you go here...

    http://forums.techguy.org/f22-s.html

    and post your questions... it's a fairly well-run support forum by/for computer folks. cause franky, you're talkin' way over my head...
    i've debated linux'ing my older computer, but after getting my feet wet with it, i decided it was beyond my abilities. so i'm stuck with windows.
    good luck!

    Comment


    • #3
      being a computer freak and have worked with linux,mac, and windows

      i would have to say my best advice would be to get a second computer to run linux

      easy fix!!!

      other wise u might have to re-partition and tweak the partition, so u could maybe try to get it onto a second hard drive.

      i know this can be done, because i've takin classes with a major computer freak, he had three hard drives one for linux, one for mac, and one for windows

      very complicated !!!

      i know it can be done because i've did it before, but to tell u the truth, i can't remember,,,,

      i'm more of a hands on type, another i can't explain to good
      Last edited by CORONAREDYJ; 09-07-2005, 07:42 PM.

      Comment


      • #4
        i accidently partitioned my hard drives while doing a reformat.

        Comment


        • #5
          i accidently partitioned my hard drives while doing a reformat.
          __________________
          i got a cj
          So if I do that, will I get a CJ too?

          Comment


          • #6
            Hey sheepjeep...
            I think your problem is one of two things: both related to the way the kernel loads the usb device.
            theory1). With the USB plugged in, the kernel (assuming its 2.4.x or newer) is going to load the driver for SCSI emulation, since anaconda is detecting an electrical current on the USB port. Thats all fine and well when your using a USB sotrage device like a thumb drive or external HDD. The problem lies in the printer being the wrong device type in /proc (?) and the system trying to mount the printer as a USB disk (check /etc/fstab and /etc/mtab by entering:
            $cat /etc/fstab -or-
            $cat /etc/mtab)
            What I would do if this is the cae is to edit /etc/initrd and disable USB support - Now, keep in mind, thats a seriously ghetto way of going about it

            theory2). Again the USB devfs is trying to use SCSI emulation to work. (what version of Mandrake are you using anyway?). If you know how, you can use insmod to remove the kernel module support for USB.....thats even more ghetto than the first one.



            In any event, I would boot without the printer and login. Then open a root shell and type:
            # tail -f /var/log/messages

            That will bring up the kernel messages (readable output of what the kernel is doing).
            After that is up, plug the printer in and watch the logs. Pay attention to what modules it's loading and any errors. Work backwards from there, trying to eliminate the problem - keeping in mind your boot sequence is what is being affected.

            It's not the printer, and it's not windows. I don;t think it's necessarily linux either. I would guess you have a version of mandrake that has an older kernel and it didnt install with the right modules to support USB printing.

            Good Luck

            Ed
            Last edited by werem00se; 09-09-2005, 08:00 PM.

            Comment


            • #7
              yea ed, its mandrake 10, i downloaded it right before the changed to mandriva. it does not matter if the printer is connected or not. what i was thinking of doing is the first the first time i can get in there with out any problems i will delet the printer driver, but ill try some of the stuff you said.

              Comment


              • #8
                after tooling around around with the usb stuff i got pluged in i figured out it was the rf receiver for my remotcontrol that came with my tv card

                Comment

                Working...
                X